13 12
Thread
Print

Black Screen problems and fixes - Many threads combined

Black Screen problems and fixes - Many threads combined

You will not be able to reply to this thread because it is in Guides section
please make any further question or comments to

The Black Screen combined Threads - discussion thread
http://forum.vc.igg.com/viewthread.php?tid=54016



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

As I was going through looking for black screen threads , I came up with about 30 or 40 of them
This thread will combine all the types of black screen problems and describe any fixes reported in theses threads

All answers are from different people... there are so many different people I am not even going to try to name them
Each paragraph under "solutions" is from a different person


Table of contents (each post describes a different problem)

2) the start up screens so you can explain /diagnose exactly when your problem happens
3) Black screen when switching game clients or to other programs (Vista, Win 7) windowed mode
4) Game freezes when playing, then you get a black screen (video card), Black screen after entering portal or when going to high sea
5) Game Crashes every 10 min, goes to black screen
6) Black Screen but will have sound
7) Black screen after clicking "start" but before you log in with password and select character.
8) Sleep mode after a couple of minutes of play
9) Black screen after clicking "start" but before you log in with password and select character, but with Error message "please update the program...."
10) Try to log in and get yellow line ad black freezing screen
11) Solving black screen by adding special DLL files
12) Was working fine, came back to black screen, game will not restart
13) Intermittent black screen, but black for all programs not just VCO.


Other helpful links that may not be black screen exactly:

VCO works on Windows 7 64 biti ? - http://forum.vc.igg.com/viewthread.php?tid=44900&extra=page%3D5

Another possible crash fix; DX8 code / bus set 4 not 8x AGP - http://forum.vc.igg.com/viewthread.php?tid=9818&extra=page%3D3

CPU requirement (too high on 64 bits?) - http://forum.vc.igg.com/viewthread.php?tid=44171&extra=page%3D3

try safemode to see if its a conflicting program crash - http://forum.vc.igg.com/viewthread.php?tid=39757&extra=page%3D4

Win 7 x64 + new hardware...will it work with VCO? - http://forum.vc.igg.com/viewthread.php?tid=43724&extra=page%3D5  (read about UAC... not run as admin)

GPU frequency - http://forum.vc.igg.com/viewthread.php?tid=47134&;extra=page%3D7

[ Last edited by xanthian31 at 2012-4-13 00:32 ]

TOP

the start up screens so you can explain /diagnose

This is the order of the start up screens you should see if program is loading correctly
I will letter them and use their letters in several of the explanations

A


B


C


D


E


F


.

[ Last edited by xanthian31 at 2012-4-16 20:25 ]

TOP

Black screen when switching game clients or to other programs

Black screen when switching game clients or to other programs (Vista, Win 7) windowed mode


Problem:
Whenever I try to run another client, I get the black screen. I've tried running two clients when all other unnecessary programs and processes have been closed so hardly any of my RAM is taken up. According to my CP meter, when there's nothing else open, its at about 31%. Anyway, I'll run the first client and log in. Then I'll try to run the second one and it'll run and everything, but when I try and go back to the other client, its a black screen. Is there a reason for this? What can I do to fix it? Is there something I have to do to my computer to be able to run two clients at once? I know some people who can run three at once.


Answers;

Step by step:
1. Start one Client and wait
1.1 As soon as you could Start the Game, you open the 2nd.
2. Now Start the Game @ Client #1
2.1 Start the 2nd Client after the first.


Right Click "Voyage Century Online" -> Settings -> "Run as Administrator"
or
right click the icon you use to start the game, go to properties. In the shortcut tab click Advanced. Then check Run as administrator. Then hit OK. Next go to the Compatibility tab and down at the bottom check... Run this program as an administrator. Then hit Apply and OK.  Now you need to click your icon and choose the update server. DO NOT START GAME YET!!!  Click your icon again and choose another update server.  Now start BOTH games. Log in to the first one, then log in to the second one. Then choose your character on the first one, then again on the second one.


You can prevent the black screen from happening by turning user Account Controls off. (not recommended is a overall computer safety issue)

If this is a Vista issue (Vista user myself), if you update to SP1, its super stable for VOC. I can run 5 accounts at once on a single machine, and the only issue is keeping track of who is where. The function of WINDOWS-TAB brought in by Vista as a replacement for ALT-TAB is great, since it lets you flip through the different screens and see a good idea what's on them.


INSTEAD OF CLICKING ALT TAB RIGHT CLICK THE DESKTOP AND THEN... CLICK SHOW DESKTOP THEN CLICK THE DIABLO GAME OR ANT GAMES THEN PLAY IT WHILE VCO IS WORKING THEN CLICK ON VCO IT WONT BE BLACK LOL...... BUT IF YOU HAVE A SCREEN SAVER REMOVE IT


Solution for Vista users who cannot enter game
Here are two solutions:

Solution one: put your mouse on the game icon, right click and choose "Run as Administrator";
Solution two: Uninstall the game and install it again in any disc other than Disk C.



1.change the resolution of the game which you want to play the same to VC'S!
2.If possible, run all the games in windows mode!
3.Press the ctrl +D to minimize all the windows,and then run the second game process!

1. change you screen settings to games one
2. play in window mode



well, I opened in window mode but i can not see the edges of the game because the window is smaller than the resolution of the game...anyone know how i can resolve this problem?

You will find that if you hover the mouse icon closely to the edge of the window, it will work similar to full-screen mode.  But it extremely annoying to run in that mode (edges are extremely sensitive and hard to hover over).  The game works best in full-screen mode when character needs to move, rotate, etc.

How to Run as Administrator permanently
This is easiest:
in windows7

Right click voyage century icon on desktop >> properties >> shotrcut tab >> advanced options button >> then check the box run as admin. >> click ok  >> click ok



How To Disable User Account Control (UAC) the Easy Way on Win 7 or Vista


Note: Disabling UAC will lead to a non secure system, so be warned.

Disable UAC on Windows Vista

Open up Control Panel, and type in “UAC” into the search box. You’ll see a link for “Turn User Account Control (UAC) on or off”:


On the next screen you should uncheck the box for “Use User Account Control (UAC)”, and then click on the OK button.


You’ll need to reboot your computer before the changes take effect, but you should be all done with annoying prompts.

Disable UAC on Windows 7

Windows 7 makes it much easier to deal with UAC settings, and in fact you don’t have to completely disable UAC if you don’t want to. Just type UAC into the start menu or Control Panel search box.


You can simply drag the slider up or down, depending on how often you want to be alerted.


If you drag it all the way down to the bottom, you’ll have disabled it entirely.

[ Last edited by xanthian31 at 2012-4-13 00:25 ]

TOP

Game freezes when playing, Black screen after entering portal

Game freezes when playing, then you get a black screen (video card)
Black screen after entering portal or when going to high sea


Problem:

Game Freeze, black screen, game restarts when changing screens
I already have this kind of prob since the game appear. Always when i play the game freezes, get a black sreen or makes a new start. This often happens when i go from high see on the land or when im on the land. Can someone help me.

2nd similar sounding problem:
Game freeze - video card problem
I am playing vco about 6 months without severe problems till 0.61 patch. After that the game suddenly freezes my pc and i have to reset. At the begging was rare but lately after i pressed start game butoon pc was freezed. All other programms are running smoothly. I have dual core intel 4800 at 1800, Nvidia geforce 7600 (256 ram), 1,5 ram,latests drivers for video card and direct x (all from official sites), 140 G free space in HD. Local technician check hardware and said that all r ok and suggest a hard disc format wich its done.I install all old downloads (backup), but cant play, pc freezes.
I ask live support, manually install patches, same again. Then he said unistall game and install again.I couldnt unistall but read solution in forum and it. Then 6 hours to download official client , put UAC (i have vista) off install and ? THE SAME PROBLEM
I used to use 3rd update server so i select it again but i get a message that can not find a .ini file and said try other server. Did that and after i pressed start game button there is a black screen as usual but before the select server screen appears there is a all white screen and then as soon as the normal screen appears pc frezees, i can hear music but cannot do any action,keybotrd and are dead and only reset is possible. HELPPPP PLEASE (Finally the problem was the video card. After yhe replacement with a new one with 1G ram everything runs fast and smooth.Thank you everyone)


Solutions:

Did you try increase your AGP Aperture to 128?
Have you re-installed the game?
Have you tried placing your desktop resolution to 16bit?
Also have you checked your CPU temperature during scenery changes?
Try reinstalling DirectX.

make sure all your drivers (esp. sound, video and windows critical updates) are up-to-date.  Are either sound or video cards embedded into your motherboard? (VCO does have issues with embedded sound/video)

check whether your computer configuration meets the requirements, particularly the video card.


Hi all, well after a few hours of looking for fixes for my problem (VCO would constantly crash to the black screen of death, I had no option but to do a hard reboot) on these forums, which in all honesty weren't much help. I decided to try my own simple fix.
The fix was to install VCO on my D drive rather than my C drive. I hope this helps someone out there.

[ Last edited by xanthian31 at 2012-4-13 00:43 ]

TOP

Game Crashes every 10 min, goes to black screen

Game Crashes every 10 min, goes to black screen


Problem:
Hy, my Core crashes every 10 minutes...
now i have a Nvidia Geforce Mx 400, (32mb), because my Nvidia Geforce Fx 5200 (256 mb) broken, i have 1,5 gb Ram, thats not a problem an Intel Dual core CPu........
I think for video card is problem... but i (tried font files fix)
and the game keeps crashing......
Olso i Have a ATI radeon 7000 serise (64mb), whit ATI the game run verry slowly and keep crashing...
What i need to do?
because i must waith 1,5 months fro my new PC

now.... i can enter In core to log on.... I think i must buy a new video card..........



The game run on Nvidia MX 400 like on Nvidia Geforce 5200(broken)

but crashes when I enter on Hs scene, and in some city...........
my sound card is integrated in matherboard (MSI)
the name os sound card is Intel Audio controler.....
-For Nvidia Geforce2 MX 400 ( 32 mb) i have lates driver from the Nvidia.com
This is my Mx 400:




Solution:
i had a broken fx 5700 once as well and by coincidence my friend lended me a nvidia 2 exctly like yours. vco had low performance but i didnt have those crash problems. well you need a new video card and the low ram doesnt help. what cpu have you got?

as you see your system is lower than the minimum required to play:

Minimum system requirements
- Intel Pentium III 500MHz or equivalent processor
- NVIDIA GeForce 2 MX400 video card
- 128 MB RAM
- 3.5GB free hard disk space

the thing is those numbers are for an older version of vco... now it takes more resources to run it so yes get a new graphic card

[ Last edited by xanthian31 at 2012-4-13 00:44 ]

TOP

Black screen but still have sound

Black screen but still have sound

Problem:
Sometimes while I am playing the whole screen turns black like it was trying to refresh itself but when it comes back to the normality the game window stays black. I only see the feather-arrow and still hear the in-game sounds what means that the game is still running. So I have to close the window and run the game again. Can anyone help me?
My specs are:
Intel Core 2 Duo CPU E7400  2.80 GHz 2.79GHz
2.00 GB RAM (inside the PC the ram card says DDR2 but in the PC properties it just says 2.00GB so I dont know if it is DDR2)
Videocard: Nvidia GeForce 6200 256MB Turbocache.

2nd similar sounding problem:
I am playing vco about 6 months without severe problems till 0.61 patch. After that the game suddenly freezes my pc and i have to reset. At the begging was rare but lately after i pressed start game butoon pc was freezed. All other programms are running smoothly. I have dual core intel 4800 at 1800, Nvidia geforce 7600 (256 ram), 1,5 ram,latests drivers for video card and direct x (all from official sites), 140 G free space in HD. Local technician check hardware and said that all r ok and suggest a hard disc format wich its done.I install all old downloads (backup), but cant play, pc freezes.
I ask live support, manually install patches, same again. Then he said unistall game and install again.I couldnt unistall but read solution in forum and it. Then 6 hours to download official client , put UAC (i have vista) off install and ? THE SAME PROBLEM
I used to use 3rd update server so i select it again but i get a message that can not find a .ini file and said try other server. Did that and after i pressed start game button there is a black screen as usual but before the select server screen appears there is a all white screen and then as soon as the normal screen appears pc frezees, i can hear music but cannot do any action,keybotrd and are dead and only reset is possible. HELPPPP PLEASE (Finally the problem was the video card. After yhe replacement with a new one with 1G ram everything runs fast and smooth.Thank you everyone)


Solutions:

I believe one of the main issues is that the VCO game video is being controlled by DirectX calls.  These generic calls can be made from other applications that can and do reset the video resolution and/or the video color palette.  The VCO game client continues to run "normally" blindly thinking the video palette and resolution have not been updated.  A simple DirectX call could be made by the client periodically to verify the desired video conditions still exist.
The only way around this condition is to not run the offending program while playing VCO.
Another common issue comes from hardware drivers that poorly supports the DirectX calls needed by VCO.  You can help verify this condition by running the Directx Diagnostic tool called DxDiag.exe  This tool usually resides in the Windows\System32 folder.


Vista is most likely culprit especialy if you alt -tab--run game as admin and set compatibility to XP by right click on game icon . IF its XP you are running this is a driver issue and also some radeon cards have troubles with this game --yes I did read your system info

ZANTOZZZZ, DXDiag is a DirectX diagnostic tool.  It can help diagnose incompatible audio/video driver support by running the tests embedded in the tool.
But as was said before, avoid screen-resolution changes (alt-tab, other programs that change resolutions, minimizing, etc).

Bad video card.

[ Last edited by xanthian31 at 2012-4-12 19:55 ]

TOP

Black screen after clicking "start"

Black screen after clicking "start" but before you log in with password and select character.

Problem:

When I click start game from the launcher a black minimized screen appears at the center of the monitor ( takes about 50% of it).

Notes:
1) This is not a multi-client issue, I am trying to run only 1 Game !
2) My laptop uses "optimus" technology to switch to my main GeeForce GT 555M video card.

computer specs hiddedn for space saving, they were not necessary for diagnosis.
Hidden content will be shown only to user with 50000 credit and above.

Extra Notes:
1) Safe mode does not help.
2) Compatibility mode does not help.
3) Running as Administrator does not help.
4) re-download does not help.
5) Disabling other processes/applications/services does not help.
6) Stopping anti-virus software does not help.
7) Changing resolution does not help.
8) re-installing (even 100% wiped) does not help.
9) User Access Control features are turned off.

ScreenShots:







Solutions:
DELETE the " logo.mpg " File in
"D:\Program Files (x86)\Voyage Century Online\voyage " or in
"D:\Program Files (x86)\Voyage Century Online\ "( Sorry forgot already which one was it. )

My logo.mpg file is in
C:\Program Files\Voyage Century Online\voyage   - Ele


[ Last edited by xanthian31 at 2012-4-13 00:44 ]

TOP

Sleep mode after few min of play.

Problem:
Sleep mode Error!
hey guys, i got this serious problem... when i play voyage century for a few min. my monitor turns off and its written in a small window ''sleep mode''
its still the same, but sometimes the screen gets black and i can see only the mouse..sometimes it goes to sleep mode


Solution:
Go to Control Panel. Click power options and set turn off monitor to never
set turn off hard disks to never see if that helps

Go to Control Panel. Click power options  and make sure system standby is set to Never and make sure power options is set to Always On. Also what operating system are you running? does it only do it on VCO or if you leave it on a webpage for a few minutes?
Mine only goes into sleep mode if I hit the sleep key on keyboard

Ok, first off, get rid of the driver updates you installed (the newer non-tested ones often cause trouble with games).  Disable any screensavers or auto-sleep modus on your computer. (right- click desktop -> screensaver / settings). Also, disable any program that might change the screen resolution on your computer. This might solve the problem.

If you get the message 'Your screen resolution is different than the deafault resolution, do you want to change to the deafault resolution?' when starting up the game, then try to change your screen resolution to 1024 X 768. This is the deafault resolution of the game. Next time you start up the game, you won't get the message but you will get fullscreen VCO. Also, this way you can safely alt + tab between VCO and other pages and apps, and even other games (if they have the same resolution as VCO).

more symptoms:
i did, everything u told me, but still i get the sleep mod crushes, yesterday, when i got one, and i restarted my pc, the black screen appeared(before entering to the computer, you know, when you turn on your PC, and the black screen is at the begining, and then the loading page) well and in that black screen it wrote error in hardware monitor, please press f1 to continue or press delete to setup screen.. and i clicked delete to setup screeen, and i searched the Hardware monitor, and there was some temperature with red, so i checked the options, the only one i had was ignore or to see the temperature, so i klicked the ignore option, saved and exisited and restarted to my PC

Now, that my friend, is a problem with your operating system, you can either re-install it from the beggining, or you can restore your computer to an early hour,cuz apparently some of your operating system Exes are compiling with Vco ones, i think i had this problem before, fixed it by re-installing the whole operating system (Xp Service Pack 2 in my case)

[ Last edited by xanthian31 at 2012-4-12 20:04 ]

TOP

with Error message "please update the program..."

Black screen after clicking "start" but before you log in with password and select character, but with Error message "please update the program..."

I re-download game more then 3 times and i install patch in vc folder all the time.


Problem:

Hello.I close game and when i try to open it again i have this problem besides this i have 2 friends who wants to play VC  but they can't..they have the same problem.What we need to do? Thanks


yes i did,i tried to uninstall and reinstall the program many times.
When i press start game immediately go to the black screen with the error message.I'm at home,my dad has the permission sometimes too but i'm sure he didnt do something wrong.I have normal computer,my operating system XP,connection i use FTP.the provider not block certain sites

Solution:

Make sure you have the latest update.   You may have loaded the main program but are there additional updates
Example:  April 2012  we are on version 0.92   but when you load the program it only gives you version 0.91  you must then download a 2nd file for the 0.91-0.92 Patch.

i had this problem before
it means either your video card isnt updated enough (i had to buy a new one, im commited to vco  haha)
or you need to uninstall (manually no uninstall program works on vco) and then do it again.

That problem usually happens when you run Core.exe directly instead of launching voyagecentury.exe first.

make sure u dont have a firewall, antivirus or any other program blocking it from getting to the internet
"fix" is a waste of time, never use it, u are better off uninstalling and reinstalling the program than using fix
other thing is maybe a bad old file, uninstall the program, delete the vco folder from the program files and run a program like CCleaner to remove all existing vco system files, that will give u a fully clean reinstall

tell your security software to 'Trust" all Vc o files
and then remove your firewall temporarily to see if that solves the problem

So as Dsofa says above... make sure you run the game program as administrator.
Double check that the game got installed in the correct path, it should be:
C >> Program Files (x86) >> Voyage Century Online
**(x86)  I think is a windows 7 designation
For at least this one attempt do not use your start up icon....start from your list of programs
start>> all program files>> Voyage Century Online >> (right click) Voyage Century Online and select Run as administrator.
Because you are running a new download... you will not be able to auto download the latest small updates unless you are the administrator.
I had the same problem as well when I downloaded the program a few weeks ago on my new computer.
If for some reason you can not run as administrator ( you are on a shared computer or some thing)... have the admin change the permissions for you so that you have administrator permissions for the voyage century files

Then there's something in your firewall that just won't let the cookies Vc o needs to run through

You are missing system.log file.
Create is manually. Then run the game.
Just open notepad. Click save as, choose "Save as type: all files" and name it system.log. Move it to that folder.

(after looking at error log): Hmm very interesting. Everything load properly, like it should. There's no errors in there.
Hmm, lets see, you said your friends get the same error when starting game? So its not just you? According to that, its probably not client problem.
Its probably OS problem. Do you by any chance use the same OS? Installed from same CD/DVD, same version?
OS - Operating system. Like Windows, Linux etc..
If you had the same OS version, installed from same CD, then we could relate this vco problem to OS, we could then maybe identify the windows service which causes this problem.
But since you said your friend lives in other city and you don't have the same programs and OS, then the chances for you two to have the same problem with OS are very very low.
Honestly, I never saw this problem before. We had all kind of problems, they are all fixed, but I never saw a problem like this.
Did you try to clean the PC with CCleaner after uninstalling the game? Like selenium already explained?
Last option I could think if is some kind of virus problem, which is unlikely. But we can check it easily. Can you enter registry? Start=>Run and type regedit. If teh PC restarts then its positive, you have a virus. If registry opens successfully, its probably not infected, but we can't tell for sure.

when u re-download the program, do u download it over the top of the old file and replace it?
if so, delete the old installation file first and then download a fresh copy, or even download the new copy in a different folder
that way u help eliminate the possibility of corruption
oh that reminds me, when u download, do u download it directly or do u use a download program?
if u download directly, since its such a large file it might be corrupting on download. try using a download manager like flashget or bittorrent


NO FINAL SOLUTION EVER POSTED FOR THIS PROBLEM

[ Last edited by xanthian31 at 2012-4-12 23:16 ]

TOP

Try to log in and get yellow line and black freezing screen

Try to log in and get yellow line and black freezing screen

Problem:
It's been a whole week since i tried to log on and after few mins in the game, even less, i got a sort of yellow line who cut my screen in two and a black freezing screen. I cant go back on my deskop, or even operate CTRL+ALT+DEL... all i have to do is to turn the power off roughly! i updated my graphic card pilots, changed resolution for the game, even restored the factory-default settings of my computer; but after reinstalling the game, same problem.
I dont understand because i tried several games with the same memory requirements as VCO and it works...
This problem happened suddenly a day without my computer falling or getting damages.




Solution:

It sounds like some of your files on the game became corrupted. You will probably have to uninstall and then reinstall the game.

you have to manually uninstall... then use a program to remove hidden files...
then reinstall from the official down load page.

Do not start game from installer program...
close all install windows and reboot
then start game as administrator the first time you use it.

More on problem
I tried thus to uninstall the game with the program CCleaner and deleted manually vco folders ( dont know how to remove hidden files if they're still on ?).
I downloaded the vco client from the website and i followed your instructions by closing all windows after installation, reboot and run as admin.
The game started like before during one hour and then...still the same problem.

Sounds like a heat issue to me, open you computer case and suck out all the dust!  Check to make sure that all the fins in the heat sinks are clean and free of blockages.

[ Last edited by xanthian31 at 2012-4-12 23:18 ]

TOP

 13 12
Thread